You are here

Error in Coc. 0.96.4 when I click on Action in Menu (win XP SP2)

Hello, when I click on Action I obtained this error:
---------------------------------------------------------------------------------------------------------------------------
Hook menuPostCommand failed: 1
couldn't execute "{C:\Program Files\Aspell\bin\aspell.exe}": no such file or directory
while executing
"exec $cmd dicts"
(procedure "spell::alldicts" line 10)
invoked from within
"spell::alldicts"
(procedure "MenuPost" line 11)
invoked from within
"MenuPost main-info .jmain.menu.info"
(in namespace inscope "::Spell" script line 1)
invoked from within
"::namespace inscope ::Spell MenuPost main-info .jmain.menu.info"
("eval" body line 1)
invoked from within
"eval $func $args"
couldn't execute "{C:\Program Files\Aspell\bin\aspell.exe}": no such file or directory
while executing
"exec $cmd dicts"
(procedure "spell::alldicts" line 10)
invoked from within
"spell::alldicts"
(procedure "MenuPost" line 11)
invoked from within
"MenuPost main-info .jmain.menu.info"
(in namespace inscope "::Spell" script line 1)
invoked from within
"::namespace inscope ::Spell MenuPost main-info .jmain.menu.info"
("eval" body line 1)
invoked from within
"eval $func $args"
---------------------------------------------------------------------------------------------------------------------------

application is shuting down and I must again running Coc. and again fill my login data.

When I click on Info (in Menu, next Action) I obtained this error:
---------------------------------------------------------------------------------------------------------------------------
Hook menuPostCommand failed: 1
couldn't execute "{C:\Program Files\Aspell\bin\aspell.exe}": no such file or directory
while executing
"exec $cmd dicts"
(procedure "spell::alldicts" line 10)
invoked from within
"spell::alldicts"
(procedure "MenuPost" line 11)
invoked from within
"MenuPost main-info .jmain.menu.info"
(in namespace inscope "::Spell" script line 1)
invoked from within
"::namespace inscope ::Spell MenuPost main-info .jmain.menu.info"
("eval" body line 1)
invoked from within
"eval $func $args"
couldn't execute "{C:\Program Files\Aspell\bin\aspell.exe}": no such file or directory
while executing
"exec $cmd dicts"
(procedure "spell::alldicts" line 10)
invoked from within
"spell::alldicts"
(procedure "MenuPost" line 11)
invoked from within
"MenuPost main-info .jmain.menu.info"
(in namespace inscope "::Spell" script line 1)
invoked from within
"::namespace inscope ::Spell MenuPost main-info .jmain.menu.info"
("eval" body line 1)
invoked from within
"eval $func $args"
---------------------------------------------------------------------------------------------------------------------------
and application is shuting down :(
Windows XP SP2, Notebook Intel Core Duo 1.8 GHz, ATI Radeon XPress 1100, 2 GB Ram

Forum: 

and when i click on File, it is same error again....but when i clicked on OK instaed Details about error application is not shuting down, but i am still not in menu :(

Bug tracked here: https://bugs.launchpad.net/coccinella/+bug/179569

Can you try to install Aspell in C:\Program Files\Aspell\bin\aspell.exe and see what happens? You can download aspell for Windows here: http://aspell.net/win32/ (you probably only need the full installer, not sure though, but you can start with that)

aspell is correct install on my disk some months ago, so I can only try your bug fix

edit:
i am looking that is only bug report, ok i will be wait on bug fix
edit 2:
yes i am sure that i have install aspel 0.50.3

As a temporary workaround it probably helps to uninstall Aspell. I could reproduce the bug under Wine and it worked again when I uninstalled Aspell.

i was uninstall aspell in the control panel and restart PC and obtained error again, but when i download aspell instalation package and try to install again, it said me that aspell is not uninstall sucessfull, click on uninstall - Yes to All and it´s working! ;-) THX

If you need spell checking, you can try the daily build here: http://coccinella.im/breakfast/

The bug should be fixed now and I tested it under Wine...so it will probably also work on a "real" Windows :-)

If there are more issues, your bug reports are welcome ;-)