You are here

Ubuntu 7.04 ---- syntax error in expression "3.14159/8" since yesterday

Coccinella is great software ! Thank you
------------------------------------------------------------------------------------------------
All worked fine until yesterday. Now when I start Coccinella :

$ /opt/Coccinella-0.96.0Linux-x86/Coccinella-0.96.0.bin

I get the appended error message. The only change I can think of are upgrading and installation of several other packages. I append the commit logs of Synaptic.
------------------------------------------------------------------------------------------------
error reading package index file /opt/Coccinella-0.96.0Linux-x86/Coccinella-0.96.0.bin/lib/app-Coccinella/bin/unix/Linux/i686/vfs1.3/pkgIndex.tcl: syntax error in expression "[package provide Tcl] error reading package index file /opt/Coccinella-0.96.0Linux-x86/Coccinella-0.96.0.bin/lib/app-Coccinella/bin/unix/Linux/i686/vfs1.3/pkgIndex.tcl: syntax error in expression "[package provide Tcl] syntax error in expression "3.14159/8": extra tokens at end of expression
while executing
"source /opt/Coccinella-0.96.0Linux-x86/Coccinella-0.96.0.bin/lib/app-Coccinella/Coccinella.tcl"
("package ifneeded" script)
invoked from within
"package require app-Coccinella"
(file "/opt/Coccinella-0.96.0Linux-x86/Coccinella-0.96.0.bin/main.tcl" line 3)
------------------------------------------------------------------------------------------------
Commit Log for Fri Aug 24 19:50:11 2007
Die folgenden Pakete wurden aktualisiert:
kdebase-bin (4:3.5.6-0ubuntu20.1) to 4:3.5.6-0ubuntu20.2
kdelibs-data (4:3.5.6-0ubuntu14) to 4:3.5.6-0ubuntu14.1
kdelibs4c2a (4:3.5.6-0ubuntu14) to 4:3.5.6-0ubuntu14.1
khelpcenter (4:3.5.6-0ubuntu20.1) to 4:3.5.6-0ubuntu20.2
Die folgenden Pakete wurden installiert:
smbfs (3.0.24-2ubuntu1.2)

Commit Log for Fri Aug 24 20:01:55 2007
Die folgenden Pakete wurden vollständig gelöscht:
smbfs

Commit Log for Fri Aug 24 20:42:47 2007
Die folgenden Pakete wurden installiert:
samba (3.0.24-2ubuntu1.2)
samba-doc-pdf (3.0.24-2ubuntu1.2)

Commit Log for Fri Aug 24 21:16:44 2007
Die folgenden Pakete wurden installiert:
winbind (3.0.24-2ubuntu1.2)

Commit Log for Fri Aug 24 21:39:38 2007
Die folgenden Pakete wurden vollständig gelöscht:
winbind

Commit Log for Fri Aug 24 21:52:19 2007
Die folgenden Pakete wurden installiert:
smbfs (3.0.24-2ubuntu1.2)

Commit Log for Fri Aug 24 21:55:41 2007
Die folgenden Pakete wurden installiert:
winbind (3.0.24-2ubuntu1.2

Commit Log for Fri Aug 24 22:20:21 2007
Die folgenden Pakete wurden installiert:
fuse-utils (2.6.3-1ubuntu2)

Commit Log for Fri Aug 24 22:25:56 2007
Die folgenden Pakete wurden installiert:
fusesmb (0.8.5-1)
libfuse2 (2.6.3-1ubuntu2)

Forum: 

I can see two reasons for this. Either somehow Tcl/Tk 8.5a* is running which gives similar error messages, or some stack corruption has occurred :-(. The latter can be extremely hard to figure out. I have just added a FAQ http://coccinella.im/node/84 of how to run from sources. Could you test this and see what happens?

I used the released version http://prdownloads.sourceforge.net/coccinella/Coccinella-0.96.0NoVoIPSrc... and Tcl/Tk 8.4 - the newest Ubuntu package.
As far as I understand we get the same error :
$ ./Coccinella.tcl
error reading package index file /opt/Coccinella-0.96.0Src/bin/unix/Linux/i686/vfs1.3/pkgIndex.tcl: syntax error in expression "[package provide Tcl] error reading package index file /opt/Coccinella-0.96.0Src/bin/unix/Linux/i686/vfs1.3/pkgIndex.tcl: syntax error in expression "[package provide Tcl] error reading package index file /opt/Coccinella-0.96.0Src/bin/unix/Linux/i686/vfs1.3/pkgIndex.tcl: syntax error in expression "[package provide Tcl] Error in startup script: syntax error in expression "3.14159/8": extra tokens at end of expression
while compiling
"expr {3.14159/8}"
while compiling
"set widgetGlobals(rotStep) [expr {3.14159/8}]"
(in namespace eval "::chasearrows" script line 11)
invoked from within
"namespace eval ::chasearrows:: {

# The public interface.
namespace export chasearrows

# Globals same for all instances of this widget.
..."
(file "/opt/Coccinella-0.96.0Src/contrib/chasearrows.tcl" line 39)
invoked from within
"source /opt/Coccinella-0.96.0Src/contrib/chasearrows.tcl"
("package ifneeded" script)
invoked from within
"package require chasearrows"
(file "/opt/Coccinella-0.96.0Src/jabber/SetupAss.tcl" line 11)
invoked from within
"source /opt/Coccinella-0.96.0Src/jabber/SetupAss.tcl"
("package ifneeded" script)
invoked from within
"package require $name"
("foreach" body line 2)
invoked from within
"foreach name $packages($class) {
package require $name
}"
("foreach" body line 2)
invoked from within
"foreach class {generic uibase application} {
foreach name $packages($class) {
package require $name
}
}"
(file "./Coccinella.tcl" line 218)

If you just start Tcl/Tk from the terminal using "wish" and then do "package require Tcl" what do you get? Test also "info patchlevel".

Mats

$ wish
% package require Tcl
8.4
% info patchlevel
8.4.14

This is bad since it points to some kind of stack corruption. The actual lines it complains about are perfectly OK so I guess that the Tcl interpreter has got completely messed up. I can only guess. Make sure you don't have the coccinella/bin/unix/Linux/i686/iaxclient/ there and then you could try also removing coccinella/bin/unix/Linux/i686/Img1.3/ since I can live without it. And yes, try also removing coccinella/bin/unix/Linux/i686/tileqt/ and see what happens.

Mats

Due to additional difficulties I decided to install Ubuntu again.
Now Coccinella is working fine again.

Just some thought: did you had libpng3 installed before? That might explain the bug as I also have this problem when I install libpng3.

--
Mvg, Sander Devrieze.

That's why I got suspicion against coccinella/bin/unix/Linux/i686/Img1.3/
Not sure if that gets statically linked or not. Also tileqt has been very problematic.

Mats

I don't think so. My new Ubuntu installation uses libpng12-0 which supersedes libpng3 and I can think of no reason for having installed libpng3 in my previous Ubuntu.

Maybe a dependency? Can you try to install it?

--
Mvg, Sander Devrieze.

I have installed libpng3 and Coccinella is still working fine.

The Coccinella crash was the first of three or four strange occurencies after I had newly partitioned my hard disc.
I have changed my hard disc three days ago and get no longer strange occurencies.

Maybe I never had a Coccinella problem ????

mfG Georg Simon

Do you really have no problems with libpng3? Did you tried to enable tileqt in the appearance section of the preferences? When you restart Coccinella, it should crash before loaded. If not, this is good news :D To fix this again, you can deinstall libpng3 and Coccinella will start up again. But no nice KDE integration :(

--
Mvg, Sander Devrieze.

I use XFCE and only parts of KDE.

In Coccinella when I choose File Preferences I get a big error message in a new window :
http://www.filecabin.com/photos/view.php?mode=gallery&g=4761
( click the image to enlarge it and again click the image to enlarge it )

Then I hit the space bar ( focus is on the OK button ) and Coccinella works again. This behaviour has been the same since I use Coccinella and independently of libpng3.

I can highlight Appearance but I cannot find anything like tileqt. What does tileqt mean ?

mfG Georg Simon

Tile qt is a theme that will make Coccinella to use Qt widgets. In this way Coccinella will adapt to the global KDE theme and will look extremely similar to native KDE applications. It's very cool, but it's broken here for some time because of this incompatible libpng version :(

--
Mvg, Sander Devrieze.